IISにOSSをインストールするための情報サイト [IIS de OSS 64bit]

IIS de OSS 64bit > Ruby on IIS > WindowsへのRubyGems1.3.5設定方法

準備

SSLEAY32.dllのダウンロードと設定

  1. OpenSSL認定のWindowsバイナリサイトにアクセス
  2. 「Win32 OpenSSL v0.9.8k Light」をクリックし「Win32OpenSSL_Light-0_9_8k.exe」をダウンロードしインストール実行
  3. インストール完了後、「ssleay32.dll」と「libeay32.dll」、「libssl32.dll」を「C:\ruby\1.8.7\bin」にコピー

zlib.dllのダウンロードと設定

  1. zlibのサイトにアクセスし「zlib compiled DLL, version 1.2.3, zipfile format」のファイルをダウンロード
  2. ダウンロードした「zlib123-dll.zip」を解凍する
  3. 解凍フォルダ内に「zlib1.dll」というファイルがあるのでコピーする
  4. コピーした「zlib1.dll」を「C:\ruby\1.8.7\bin」に貼り付ける
  5. 貼り付けた「zlib1.dll」を「zlib.dll」にリネームする

iconv.dllのダウンロードと設定

  1. 配布しているサイト(例:http://www.kaoriya.net/#LIBICONV)にアクセスし「Libiconv DLL 1.10-20060516 for Windows」からファイルをダウンロード
  2. ダウンロードしたファイルを解凍
  3. 解凍フォルダ内に「iconv.dll」というファイルがあるのでコピーする
  4. コピーした「iconv.dll」を「C:\ruby\1.8.7\bin」に貼り付ける

MSVCR71.dllのダウンロードと設定

  1. 配布しているサイト(例:http://reddog.s35.xrea.com/wiki/MSVCR71.DLL.html)にアクセスし「msvcr71.dll.zip」からファイルをダウンロード
  2. ダウンロードしたファイルを解凍
  3. 解凍フォルダ内に「msvcr71.dll」というファイルがあるのでコピーする
  4. コピーした「msvcr71.dll」を「C:\ruby\1.8.7\bin」に貼り付ける

ダウンロード

  1. RubyGemsのマニュアルサイトに行きDownloadsをクリック
  2. 「rubygems-1.3.5.zip」をクリックしダウンロード
  3. ダウンロードしたファイルを展開
  4. 展開したフォルダ内にあるsetup.rbを実行(コマンドプロンプトで)
    C:\ruby\1.8.7\bin\ruby.exe setup.rb
  5. 以下のようにインストールが進行し完了する
    RubyGems 1.3.5 installed
    
    ・ソ=== 1.3.5 / 2009-07-21
    
    Bug fixes:
    
    * Fix use of prerelease gems.
    * Gem.bin_path no longer escapes path with spaces. Bug #25935 and #26458.
    
    Deprecation Notices:
    
    * Bulk index update is no longer supported (the code currently remains, but not
      the tests)
    * Gem::manage_gems was removed in 1.3.3.
    * Time::today was removed in 1.3.3.
    
    
    ------------------------------------------------------------------------------
    
    RubyGems installed the following executables:
            C:/ruby/1.8.7/bin/gem
    "ソ"って何だw;

これでRubyGemsのインストールが完了です。インストーラのログにあるとおり「C:\ruby\1.8.7\bin\gem」としてインストールされました。

RubyGemsでパッケージ追加

RubyGemsを利用してパッケージを追加する場合は以下の手順で出来ます。

依存したパッケージもインストールする場合

  1. コマンドプロンプトを起動
    cd C:\ruby\1.8.7\bin
    gem install パッケージ名 --include-dependencies
  2. (例)Ruby on Railsパッケージをインストールする場合
    gem install rails --include-dependencies

依存したパッケージをインストールしない場合

  1. コマンドプロンプトを起動
    cd C:\ruby\1.8.7\bin
    gem install パッケージ名
  2. (例)MySQLパッケージをインストールする場合
    gem install mysql

RubyGemsでバージョンを指定したパッケージ追加

  1. コマンドプロンプトを起動
    cd C:\ruby\1.8.7\bin
    gem install パッケージ名 --version XXXXX
  2. (例)gettextパッケージの1.93.0をインストールする場合
    gem install gettext --version 1.93.0

RubyGemsでパッケージ削除

  1. コマンドプロンプトを起動
    cd C:\ruby\1.8.7\bin
    gem uninstall パッケージ名
  2. (例)gettextパッケージをインストールする場合
    gem uninstall gettext

コメント


トップ   差分 バックアップ リロード   一覧 単語検索 最終更新   ヘルプ
Last-modified: 2010-02-21 (日) 09:30:20 (3191d)